Uploaded image for project: 'XJDF / JDF'
  1. XJDF / JDF
  2. JDF-650

allow XJDF/@Version in XJDF 2.0

    XMLWordPrintable

    Details

    • Draft:
      Hide

      Table 3.1: XJDF
      <2.0 copy from 2.1 and modify>

      Version ?

      New in XJDF 2.1|
      enumeration| @Version SHALL define the version of the XJDF document. The value of
      @Version SHALL be "2.0" 2.1 for documents that comply to this specification. A
      value of "2.0" MAY be specified for XJDF elements that comply with XJDF 2.0
      in all aspects except for the presence of @Version.

      Allowed values are:
      2.0 - Prior version.
      2.1
      - This version.|

      <2.1 modify>

      Version ?

      New in XJDF 2.1|
      enumeration| @Version SHALL define the version of the XJDF document. The value of
      @Version SHALL be "2.1" for documents that comply to this specification. A
      value of "2.0" MAY be specified for XJDF elements that comply with XJDF 2.0
      in all aspects except for the presence of @Version.

      Allowed values are:
      2.0 - Prior version.
      2.1 - This version.|

      <Apply same procedure to table 7.1 XJMF Element>

      Show
      Table 3.1: XJDF <2.0 copy from 2.1 and modify> Version ? New in XJDF 2.1 | enumeration| @Version SHALL define the version of the XJDF document. The value of @Version SHALL be "2.0" 2.1 for documents that comply to this specification. A value of "2.0" MAY be specified for XJDF elements that comply with XJDF 2.0 in all aspects except for the presence of @Version. Allowed values are: 2.0 - Prior version. 2.1 - This version.| <2.1 modify> Version ? New in XJDF 2.1 | enumeration| @Version SHALL define the version of the XJDF document. The value of @Version SHALL be "2.1" for documents that comply to this specification. A value of "2.0" MAY be specified for XJDF elements that comply with XJDF 2.0 in all aspects except for the presence of @Version. Allowed values are: 2.0 - Prior version. 2.1 - This version.| <Apply same procedure to table 7.1 XJMF Element>

      Description

      we added wording to the spec (2.1) that enables use of version in 2.1 documents that otherwise comply with 2.0

      should we add @Version="2.0" to the 2.0 schema to reflect this?

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                prosi Rainer Prosi
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: